Discussion: Un projet de forum
Afficher un message
Vieux 06/01/2019, 08h28   #10
Mondo
 
Date d'inscription: 13/02/2017
Messages: 231
Par défaut Re : Un projet de forum

Citation:
Envoyé par Mondo Voir le message
Tel quel, il passe pas mais une bonne partie du travail est portable et j'ai commencé à le porter. Les modules, bien sûr, ne passent pas ..
Citation:
Envoyé par MarcXimuS Voir le message
C'est ce que je trouve dommage. Tant d'effort, installer des modules indépendants pour améliorer l'expérience utilisateur mais ce n'est plus compatible.

Pour faire ce genre de migration, est-ce que tu vas devoir désactiver tout les modules et ensuite faire la mises à jour?
Réponse à cette partie ce matin.

Portable dans le sens que pour une bonne partie du travail de VB 3.8.11, ce sont des éditions de templates. Il s'agira seulement de ré-éditer les templates de VB5 pour obtenir le même résultat que celui de VB 3.8.11.

Les modules VB 3.8.11 eux ne sont pas portables puisqu'ils ne sont pas compatibles. Ils devront être désinstallés avant la migration. Si on veut les conserver sous vB5 Connect, il faut adapter le code à celui de VB5 Connect. Des codeurs peuvent faire la job moyennant des $ et le rendre compatible à celui de VB5 Connect.

Je suis convaincu que le code 3.8.11 vers 3.8.12 va être disponible en temps lieu sur Vbulletin.org (ou ailleurs sur un autre site) pour ceux qui ont une license VB 3.8.11 mais ce sera payant et seulement pour ceux qui ont une license VB 3.8.11. Ils devront payer 100$, 200$ peut-être plus ...pour cette version 3.8.12.

'Honnêtement', ce sera pas un si gros investissement pour ceux qui ont un VB 3.8.11 très personnalisé comme le mien surtout qu'un VB 3.8.12 sera compatible pour des années et des années supplémentaires.

Mon estimé sur le temps de vie:
- 3.8.11 (2 ans en hébergement partagé en masquant les erreurs PHP, 5 ans sur serveur dédié non-cPanel sécurisé, j'ai déjà passé par là dans le passé)
- 3.8.12 (10 ans et plus selon la même démarche).

Mon projet utilisera à la fois mes licenses 3.8.12 et Vb5 Connect. Je suis vBulletin 'Addict' à 200%.
Mondo est déconnecté   Réponse avec citation